Hotfix for latest ESI issues

Lately there has been issues with importing structure markets – “Service Unavailable”. Unfortunately, this prevented successfully imported prices from saving. The latest releases works around this issue:

  • [new] context menu in the Manufacturing Planner for added items
  • [fixed] edge-case crash in Market Browser
  • [changed] saving successfully imported prices regardless of error
  • Jon Draper

    Thanks!

  • Moon Stone

    Thank you!

  • Gabriel Luiz Freitas Almeida

    I still am unable to import market data. Getting this error:
    /v1/markets/10000023/history/?type_id=34151: Error transferring https://esi.tech.ccp.is/v1/markets/10000023/history/?type_id=34151&datasource=tranquility – server replied: Not Found (SSO: 0)

    Sorry if this isn’t the right place to post this.

    • Kamil Rojewski

      Your data should be imported anyway. This is a problem with the latest SDE.

      • Nicola Luzi

        I’m getting the same error, data import doesn’t seem finished. Any idea to work around this?

        • Kamil Rojewski

          How do you know the import did not succeed?

          • Nicola Luzi

            I can’t browse said data from the mkt analysis tab, that’s why I’m assuming import didnt go well.

          • Kamil Rojewski

            You won’t be able to see items which do not have history. Unfortunately, this is a SDE issue and there’s no need one.

    • Chas Hopkins

      I’m getting a similar error but only on Jita prices. Unfortunately price
      import from anywhere else doesn’t seem to work, tried Rens, Dodixie,
      Amarr …

      For Jita the dialog just sits there saving…

      • Kamil Rojewski

        What is the exact error?

        • Chas Hopkins

          tbh can’t remember. I’ve uninstalled now. UI is confused, download this n that n that x10 … but final killer is it crashed my pc when importing blueprints. So byebye an thnx for all the fish

          • Kamil Rojewski

            That’s strange. Can you tell me what usability problems you had? I will gladly fix those.

    • SkepticalMystic

      I’m getting this same error. No data loads. The market analysis is currently unusable.

      • Kamil Rojewski

        For what items are you loading the data?

        • SkepticalMystic

          Normally I load all items. I had tried a few other combinations initially and saw the same results, not sure exactly which combinations now. I shaved it down to just Ships/Ship Equipment/Skills and it still got the error, but the data went ahead and loaded. Any testing I’ve done with just one category has worked so far today. Haven’t identified which items cause it to not load anything yet.

          • Kamil Rojewski

            Well, the data should be loaded regardless if there were errors for some items or not. If you give me the error messages, I can tell you which items are faulty ones.